Narzędzie Zaznacz umożliwia określenie, które elementy mają zostać zmodyfikowane przy użyciu innych narzędzi lub poleceń. Elementy wybrane za pomocą narzędzia Zaznacz nazywane są zbiorem zaznaczenia. Narzędzie Zaznacz można aktywować z paska narzędzi głównych lub menu Narzędzia.
Skrót klawiszowy: Spacja

Zaznaczanie jednego elementu

Program SketchUp umożliwia zaznaczanie zarówno pojedynczych elementów, jak i zbiorów elementów. Aby zaznaczyć jeden element:

  1. Wybierz narzędzie Zaznacz. Kursor zmieni się w strzałkę.
  2. Kliknij wybrany element. Wybrany element zostanie zaznaczony na niebiesko.

Zaznaczanie kilku elementów

Zaznaczanie kilku elementów (zbiór zaznaczenia) jest przydatne, gdy jedna operacja ma zostać wykonana na więcej niż jednym elemencie. W przypadku zaznaczania kilku elementów stosowana jest rozciągana ramka zaznaczania, którą można objąć wszystkie żądane elementy. Aby zaznaczyć kilka elementów:

  1. Wybierz narzędzie Zaznacz. Kursor zmieni się w strzałkę.
  2. Kliknij i przytrzymaj przycisk myszy w pobliżu elementu, od którego chcesz rozpocząć ramkę zaznaczania.
  3. Przeciągnij kursor, aby rozciągnąć ramkę zaznaczania na wszystkie elementy, które mają zostać zaznaczone.
  • Kliknięcie po prawej stronie elementów i przeciągnięcie kursora na lewo, nazywane zaznaczaniem w trybie przecinania, powoduje zaznaczenie wszystkich elementów znajdujących się w ramce, nawet tych, które znajdują się w niej tylko częściowo. Na poniższym rysunku pokazano zaznaczanie od prawej do lewej strony, powodujące zaznaczenie dwóch komponentów, mimo że żaden z nich nie znajduje się w całości w obrębie ramki zaznaczania.


  • Kliknięcie po lewej stronie elementów i przeciągnięcie kursora na prawo, nazywane zaznaczaniem w trybie okna, powoduje zaznaczenie tylko tych elementów, które w całości znajdują się w ramce zaznaczania. Na poniższym rysunku pokazano zaznaczanie od lewej do prawej strony, powodujące zaznaczenie jednego komponentu, ponieważ tylko on (lewy głośnik) znajduje się w całości w obrębie ramki zaznaczania.



4. Zwolnij przycisk myszy, gdy wszystkie żądane elementy będą albo częściowo (zaznaczanie od lewej do prawej) albo całkowicie (zaznaczanie od prawej do lewej) zawarte w ramce zaznaczania.

Dodawanie i usuwanie elementów ze zbioru zaznaczenia

Stosując narzędzie Zaznacz w połączeniu z jednym lub kilkoma klawiszami modyfikującymi można dodawać lub usuwać elementy ze zbioru zaznaczenia.


Dodawanie elementów do zbioru zaznaczenia (Ctrl)
Aby dodać elementy, pojedynczo, do zbioru zaznaczenia, naciśnij i przytrzymaj klawisz Ctrl (kursor zmieni się w strzałkę ze znakiem plus), klikając dodatkowe elementy. Innym sposobem dodawania elementów, pojedynczo, do zbioru zaznaczenia jest naciśnięcie i przytrzymanie klawisza Shift (kursor zmieni się w strzałkę ze znakami plus i minus) i klikanie dodatkowych elementów.
Zmiana stanu zaznaczenia elementu (Shift)
Aby zmienić stan zaznaczenia elementu (anulować zaznaczenie elementu aktualnie zaznaczonego lub zaznaczyć aktualnie niezaznaczony element), naciśnij i przytrzymaj klawisz Shift (kursor zmieni się w strzałkę ze znakami plus i minus), klikająć żądane elementy.
Usuwanie elementów ze zbioru zaznaczenia (Shift+Ctrl)
Aby usunąć elementy ze zbioru zaznaczenia, naciśnij i przytrzymaj jednocześnie klawisze Shift i Ctrl (kursor zmieni się w strzałkę ze znakiem minus), klikając żądane elementy spośród aktualnie zaznaczonych. Innym sposobem usuwania elementów, pojedynczo, ze zbioru zaznaczenia jest naciśnięcie i przytrzymanie klawisza Shift (kursor zmieni się w strzałkę ze znakami plus i minus) oraz klikanie żądanych elementów.

Porada: :Aby móc szybko ponownie zaznaczyć ten sam zbiór elementów, utwórz grupę z elementów tworzących zbiór zaznaczenia. Aby uzyskać więcej informacji, patrz Grupa.

Powiększanie zbioru zaznaczenia za pomocą myszy

Dzięki szybkim kilkukrotnym kliknięciom narzędziem Zaznacz można automatycznie dodawać elementy do zbioru zaznaczenia. Kliknij element raz, aby go zaznaczyć. Kliknij element, krawędź lub płaszczyznę szybko dwukrotnie, aby zaznaczyć odpowiednie płaszczyzny lub krawędzie. Kliknij element, krawędź lub płaszczyznę szybko trzykrotnie, aby zaznaczyć tę krawędź lub płaszczyznę wraz ze wszystkimi elementami z nią połączonymi. Na poniższym rysunku pokazano sekwencję klikania/zaznaczania.



Porada: :Aby móc szybko ponownie zaznaczyć ten sam zbiór elementów, utwórz grupę z elementów tworzących zbiór zaznaczenia. Aby uzyskać więcej informacji, patrz Grupa.

Zaznaczanie i odznaczanie całej geometrii

Aby zaznaczyć wszystkie widoczne elementy modelu, wybierz opcję Zaznacz wszystko z menu Edycja lub naciśnij klawisze Ctrl+A na klawiaturze. Aby usunąć zaznaczenie wszystkich aktualnie zaznaczonych elementów, wybierz opcję Odznacz wszystko z menu Edycja, naciśnij klawisze Ctrl+T lub kliknij dowolne puste miejsce w obszarze rysowania.