Materiały w programie SketchUp są nakładane w formie sąsiadujących obrazów, co oznacza, że dany wzór lub obraz jest powtarzany zarówno w pionie, jak i w poziomie na całych malowanych elementach. Za pomocą narzędzia Ustaw teksturę można na różne sposoby dostosowywać materiał na danej powierzchni, np. zmieniać jego położenie, rozmiar lub zniekształcać. Ponadto narzędzie to umożliwia wykonywanie unikalnych operacji na obrazach, takich jak malowanie obrazu zagiętego na narożniku lub rzutowanie obrazu na model. Narzędzie Ustaw teksturę można aktywować z menu kontekstowego płaszczyzny.

Uwaga! Za pomocą narzędzia Ustaw teksturę można modyfikować tylko tekstury zastosowane na płaskich powierzchniach.Tekstury zastosowanej na wygiętej powierzchni nie można edytować jako jednej całości, ale po wybraniu opcji Widok > Ukryta geometria można edytować teksturę na poszczególnych płaszczyznach tworzących wygiętą powierzchnię.

Uwaga! Zazwyczaj tekstury oznaczają podzbiór materiałów. Jednak w tym rozdziale terminy „materiał” i „tekstura” są stosowane zamiennie.

Zmiana położenia materiału

Zmiana położenia materiału jest najłatwiejszą z operacji wykonywanych przy użyciu narzędzia Ustaw teksturę. Aby zmienić położenie materiału:
  1. Kliknij materiał prawym przyciskiem myszy, aby wyświetlić jego menu kontekstowe.
  2. Wybierz opcję Pozycjonowanie z podmenu Tekstura. Na materiale zostanie wyświetlona matryca złożona z kropkowanych linii, wskazujących pojedyncze „płytki” materiału. Kursor zmieni się w dłoń i wyświetlone zostaną cztery szpilki.
  3. Przeciągnij kursor na powierzchni, aby zmienić położenie tekstury. Aby obrócić obraz złożony z „płytek”, ponownie kliknij powierzchnię prawym przyciskiem myszy i wybierz opcję Obróć lub Przerzuć.
  4. Po zakończeniu modyfikowania tekstury kliknij prawym przyciskiem myszy i wybierz opcję Wykonano lub po prostu kliknij poza teksturą, aby zakończyć pracę narzędzia Ustaw teksturę.

Porada: Aby przywrócić poprzednie położenie materiału, naciśnij klawisz Esc w dowolnym momencie podczas edycji. Aby anulować całą operację ustawiania tekstury, naciśnij klawisz Esc dwukrotnie. W dowolnym momencie ustawiania tekstury można się cofnąć o jeden krok poprzez kliknięcie prawym przyciskiem myszy i wybranie opcji Cofnij z menu kontekstowego.

Szpilki ustalające położenie materiału

Narzędzie Ustaw teksturę wykorzystuje szpilki do manipulowania materiałem. Szpilki można przesuwać lub przeciągać. Przesuwanie powoduje tylko przemieszczanie szpilki w różne miejsca na materiale. Przeciąganie powoduje określone manipulacje materiałem, np. zmianę rozmiaru lub przekrzywienie.
Narzędzie Ustaw teksturę ma dwa tryby: tryb przytwierdzonych szpilek i tryb nieprzytwierdzonych szpilek.

Manipulowanie materiałem w trybie przytwierdzonych szpilek

Tryb przytwierdzonych szpilek umożliwia skalowanie, przekrzywianie, ścinanie i zniekształcanie tekstury, podczas gdy co najmniej jedna szpilka pozostaje zablokowana (przytwierdzona). Tryb przytwierdzonych szpilek najlepiej nadaje się do materiałów układanych jak cegły lub dachówki. Aby manipulować materiałem w trybie przytwierdzonych szpilek:
  1. Kliknij materiał prawym przyciskiem myszy, aby wyświetlić jego menu kontekstowe.
  2. Wybierz opcję Pozycjonowanie z podmenu Tekstura. Na materiale zostanie wyświetlona matryca złożona z kropkowanych linii, wskazujących pojedyncze „płytki” materiału. Kursor zmieni się w dłoń i wyświetlone zostaną cztery szpilki.
  3. Kliknij materiał prawym przyciskiem myszy.
  4. Kliknij opcję Przytwierdź szpilki, jeśli nie znajduje się przy niej symbol „ptaszka”. Przy szpilkach wyświetlone zostaną kolorowe ikony, z których każda oznacza konkretną operację ustawiania tekstury.


  5. Dokonaj modyfikacji materiału, klikając, przytrzymując i przeciągając jedną ze szpilek. Aby uzyskać więcej informacji, patrz część „Opcje trybu przytwierdzonych szpilek.”

    Uwaga! Jednokrotne kliknięcie szpilki powoduje jej chwycenie, umożliwiając przesunięcie w inne miejsce na teksturze. Nowe położenie będzie punktem początkowym dla wszelkich operacji w trybie przytwierdzonych szpilek. Operacja ta działa zarówno w trybie przytwierdzonych szpilek, jak i w trybie nieprzytwierdzonych szpilek

  6. Po zakończeniu modyfikowania tekstury kliknij prawym przyciskiem myszy i wybierz opcję Zakończ lub po prostu kliknij poza teksturą, aby zakończyć pracę narzędzia Ustaw teksturę.
Opcje trybu przytwierdzonych szpilek

Ikona i szpilka przesuwania: Przeciągnij (kliknij i przytrzymaj) ikonę lub szpilkę przesuwania, aby zmienić położenie tekstury. Po zakończeniu modyfikowania tekstury kliknij prawym przyciskiem myszy i wybierz opcję Zakończ lub po prostu kliknij poza teksturą, aby zakończyć pracę. W tym celu można również nacisnąć klawisz Enter (Return).

Ikona i szpilka skalowania/obracania: Ikona lub szpilka skalowania/obracania umożliwia skalowanie materiału i obracanie o dowolny kąt, na podstawie umiejscowienia przytwierdzonej szpilki przesuwania. Przeciąganie kursora bliżej lub dalej od szpilki odniesienia powoduje skalowanie materiału. Przeciąganie ikony wokół szpilki odniesienia powoduje obracanie materiału. W kierunku, w którym obracany jest materiał, wyświetlany jest przerywany łuk. W przypadku przytrzymania kursora na przerywanym łuku materiał będzie się obracał, ale nie będzie skalowany.
Zauważ, że punkty przerywanych linii lub łuków wskazują bieżący i początkowy rozmiar tekstury dla informacji. Aby powrócić do początkowego rozmiaru, przesuń kursor na oryginalny łuk lub linię. Można również wybrać opcję Zresetuj z menu kontekstowego. Należy jednak pamiętać, że wybór opcji Zresetuj oprócz zresetowania skalowania powoduje również zresetowanie obracania.

Ikona i szpilka skalowania/ścinania: Ikona lub szpilka skalowania/ścinania umożliwia jednoczesne pochylanie lub ścinanie mi zmianę rozmiaru materiału. Zauważ, że podczas tej operacji dwie dolne szpilki pozostają nieruchome.

Ikona i szpilka zniekształcania: Ikona lub szpilka zniekształcania umożliwia perspektywiczną korekcję materiału. Funkcja ta jest przydatna przy umieszczaniu zdjęć na geometrii.

Manipulowanie materiałem w trybie nieprzytwierdzonych szpilek

W trybie nieprzytwierdzonych szpilek działanie szpilek nie jest ograniczane, co umożliwia ich przeciąganie w dowolne miejsca w celu zniekształcania materiału tak, jakby był on rozciągany na bębnie. Tryb nieprzytwierdzonych szpilek najlepiej nadaje się do ustawiania położenia i usuwania zniekształceń z fotografii. Aby manipulować materiałem w trybie nieprzytwierdzonych szpilek:
  1. Kliknij materiał prawym przyciskiem myszy, aby wyświetlić jego menu kontekstowe.
  2. Wybierz opcję Pozycjonowanie z podmenu Tekstura. Na materiale zostanie wyświetlona matryca złożona z kropkowanych linii, wskazujących pojedyncze „płytki” materiału. Kursor zmieni się w dłoń i wyświetlone zostaną cztery szpilki.
  3. Kliknij materiał prawym przyciskiem myszy.
  4. Kliknij opcję Przytwierdź szpilki, jeśli znajduje się przy niej symbol „ptaszka”. Pojawią się cztery szpilki.


  5. Dokonaj modyfikacji materiału, klikając, przytrzymując i przeciągając jedną ze szpilek.

    Uwaga! Jednokrotne kliknięcie szpilki powoduje jej chwycenie, umożliwiając przesunięcie w inne miejsce na teksturze. Nowe położenie będzie punktem początkowym dla wszelkich operacji w trybie przytwierdzonych szpilek. Operacja ta działa zarówno w trybie przytwierdzonych szpilek, jak i w trybie nieprzytwierdzonych szpilek.

  6. Po zakończeniu modyfikowania tekstury kliknij prawym przyciskiem myszy i wybierz opcję Zakończ lub po prostu kliknij poza teksturą, aby zakończyć pracę narzędzia Ustaw teksturę.

Manipulowanie materiałem w postaci obrazu w trybie nieprzytwierdzonych szpilek

Tryb nieprzytwierdzonych szpilek jest najbardziej przydatny w przypadku stosowania obrazu jako podstawy geometrii. Na przykład, obraz przedstawiający drzwi można wykorzystać jako bazę dla realistycznie wyglądających drzwi w modelu programu SketchUp. Aby manipulować obrazem w trybie nieprzytwierdzonych szpilek:
  1. Utwórz prostokątną płaszczyznę.
  2. Wybierz menu Plik > Importuj, aby wstawić obraz, np. zdjęcie prawdziwych drzwi. Wyświetlone zostanie okno dialogowe otwierania plików.
  3. Wybierz format obrazu z listy rozwijanej Pliki typu.
  4. Kliknij opcję Użyj jako tekstury.
  5. Wybierz plik obrazu.
  6. Kliknij przycisk Otwórz.
  7. Kursor zmieni się w narzędzie Wypełnienie kolorem z doczepionym obrazem.
  8. Kliknij jeden narożnik płaszczyzny, aby ustawić punkt początkowy tekstury.
  9. Przeciągnij kursor od punktu początkowego tak, aby rozciągnąć teksturę na prostokątnej płaszczyźnie.
  10. Kliknij ponownie, aby umieścić teksturę na prostokątnej płaszczyźnie.
  11. Kliknij materiał prawym przyciskiem myszy, aby wyświetlić jego menu kontekstowe.
  12. Wybierz opcję Pozycjonowanie z podmenu Tekstura. Na materiale zostanie wyświetlona matryca złożona z kropkowanych linii, wskazujących pojedyncze „płytki” materiału. Kursor zmieni się w dłoń i wyświetlone zostaną cztery szpilki.
  13. Kliknij teksturę prawym przyciskiem myszy.
  14. Kliknij opcję Przytwierdź szpilki, jeśli znajduje się przy niej symbol „ptaszka”.
  15. Dokonaj modyfikacji materiału, klikając, przytrzymując i przeciągając jedną ze szpilek.

    Uwaga! Jednokrotne kliknięcie szpilki powoduje jej chwycenie, umożliwiając przesunięcie w inne miejsce na teksturze. Nowe położenie będzie punktem początkowym dla wszelkich operacji w trybie przytwierdzonych szpilek. Operacja ta działa zarówno w trybie przytwierdzonych szpilek, jak i w trybie nieprzytwierdzonych szpilek.

  16. Po zakończeniu modyfikowania tekstury kliknij prawym przyciskiem myszy i wybierz opcję Zakończ lub po prostu kliknij poza teksturą, aby zakończyć pracę narzędzia Ustaw teksturę.

Opcje menu kontekstowego trybu przytwierdzonych szpilek i trybu nieprzytwierdzonych szpilek

Aby wyświetlić menu kontekstowe tekstury, kliknij ją prawym przyciskiem myszy podczas korzystania z narzędzia Ustaw teksturę.
Zakończ: Wybór opcji Zakończ powoduje zakończenie pracy narzędziem Ustaw teksturę i zapisanie bieżącego położenia tekstury.
Zresetuj: Wybór opcji Zresetuj powoduje zresetowanie położenia tekstury i przywrócenie położenia sprzed zastosowania narzędzia Ustaw teksturę.
Przerzuć: Opcja Przerzuć umożliwia odwracanie tekstury w poziomie (lewa/prawa) lub w pionie (góra/dół).
Obróć: Opcja Obróć umożliwia obracanie tekstury o jeden z trzech kątów. 90, 180 lub 270 stopni.
Przytwierdź szpilki: Każdy kolejny wybór opcji Przytwierdź szpilki powoduje przełączanie między trybem przytwierdzonych szpilek a trybem nieprzytwierdzonych szpilek.
Cofnij: Wybór opcji Cofnij powoduje cofnięcie wykonania ostatniego polecenia związanego z położeniem tekstury. W przeciwieństwie do polecenia cofania z menu Edycja, to polecenie przy każdym użyciu cofa tylko jedną operację.
Ponów: Wybór opcji Ponów powoduje anulowanie operacji cofania, przywracając stan tekstury sprzed zastosowania polecenia Cofnij.

Uwaga! Wybór menu Edycja > Cofnij i naciśnięcie przycisku Cofnij powodują cofnięcie wszystkich operacji wykonanych podczas ustawiania położenia tekstury. Wybór menu Edycja > Ponów powoduje anulowanie operacji cofania z menu Edycja > Cofnij, przywracając ostatnią wykonaną operację ustawiania położenia tekstury.

Owijanie materiałów wokół narożników

Narożnik można owinąć teksturą dokładnie tak, jak owija się prezent papierem. Aby owinąć teksturę wokół narożników:
  1. Utwórz trójwymiarowy sześcian.
  2. Wybierz menu Plik > Importuj, aby wstawić obraz.
  3. Wybierz format obrazu z listy rozwijanej Pliki typu.
  4. Zaznacz opcję Użyj jako tekstury
  5. Wybierz plik obrazu.
  6. Kliknij przycisk Otwórz. Kursor zmieni się w narzędzie Zaznacz z doczepionym obrazem.
  7. Kliknij w miejscu, w którym ma się znajdować punkt początkowy obrazu.
  8. Przeciągnij kursor od punktu początkowego tak, aby rozciągnąć obraz.
  9. Kliknij ponownie, aby umieścić obraz.
  10. Wybierz narzędzie Wypełnienie kolorem. Kursor zmieni się w wiadro z farbą i uruchomiona zostanie przeglądarka materiałów.
  11. Naciśnij i przytrzymaj klawisz Alt, gdy włączone jest narzędzie Wypełnienie kolorem, aby zmienić kursor w zakraplacz.
  12. Kliknij materiał zakraplaczem, aby pobrać jego próbkę.
  13. Zwolnij klawisz Alt.
  14. Nałóż pobraną teksturę na pozostałe części modelu. Narożniki zostaną owinięte teksturą.


Owijanie materiału wokół walca

Teksturę można również owinąć wokół walca. Aby owinąć teksturę, np. obraz, wokół walca:
  1. Utwórz walec.
  2. Wybierz menu Plik > Importuj, aby wstawić obraz.
  3. Wybierz format obrazu z listy rozwijanej Pliki typu.
  4. Zaznacz opcję Użyj jako tekstury
  5. Wybierz plik obrazu.
  6. Kliknij przycisk Otwórz. Kursor zmieni się w narzędzie Zaznacz z doczepionym obrazem.
  7. Kliknij w miejscu, w którym ma się znajdować punkt początkowy obrazu.
  8. Przeciągnij kursor od punktu początkowego tak, aby rozciągnąć obraz.
  9. Kliknij ponownie, aby umieścić obraz.
  10. Naciśnij i przytrzymaj klawisz ALT, gdy włączone jest narzędzie Wypełnienie kolorem. Kursor zmieni się w zakraplacz.
  11. Kliknij materiał zakraplaczem aby pobrać jego próbkę. Zwolnij klawisz ALT.
  12. Nałóż materiał na walec. Materiał zostanie automatycznie owinięty wokół walca i, w razie potrzeby, powielony w celu owinięcia całego modelu.

Zmiana położenia materiału na ukrytej geometrii

Istnieje możliwość dostosowania tekstury na jednej z płaszczyzn, np. na jednej płaszczyźnie walca, a następnie zastosowania zmienionej tekstury na całej wygiętej powierzchni walca. Aby dostosować teksturę (na przykładzie walca):
  1. Utwórz walec.
  2. Wybierz menu Plik > Importuj, aby wstawić obraz.
  3. Wybierz format obrazu z listy rozwijanej Pliki typu.
  4. Zaznacz opcję Użyj jako tekstury
  5. Wybierz plik obrazu.
  6. Kliknij przycisk Otwórz. Kursor zmieni się w narzędzie Zaznacz z doczepionym obrazem.
  7. Kliknij w miejscu, w którym ma się znajdować punkt początkowy obrazu.
  8. Przeciągnij kursor od punktu początkowego tak, aby rozciągnąć obraz.
  9. Kliknij ponownie, aby umieścić obraz.
  10. Kliknij materiał w przeglądarce materiałów. Kursor zmieni się w narzędzie Wypełnienie kolorem.
  11. Nałóż materiał na walec. Materiał zostanie automatycznie owinięty wokół walca i w razie potrzeby, powielony w celu owinięcia całego modelu.
  12. Wybierz menu Widok > Ukryta geometria.
  13. Zaznacz jedną z płaszczyzn walca.
  14. Kliknij zaznaczoną płaszczyznę prawym przyciskiem myszy. Wyświetlone zostanie menu kontekstowe płaszczyzny.
  15. Wybierz opcję Tekstura > Pozycjonowanie.
  16. Zmień położenie tekstury na płaszczyźnie.
  17. Pobierz próbkę zmodyfikowanej tekstury za pomocą przycisku zakraplacza w przeglądarce materiałów lub używając klawisza Alt wraz z narzędziem Wypełnienie kolorem.
  18. Kliknij menu Widok > Ukryta geometria, aby wyłączyć ukrytą geometrię.
  19. Nałóż pobraną, zmodyfikowaną teksturę na pozostałe części walca. Tekstura będzie wyglądała tak, jakby została zmodyfikowana na całym walcu.

Rzutowanie materiału

Funkcja umieszczania tekstur programu SketchUp umożliwia również rzutowanie materiałów lub obrazów na płaszczyzny w sposób podobny, jak przy użyciu rzutnika. Funkcja ta jest szczególnie przydatna w przypadku rzutowania obrazu topograficznego na model jakiegoś terenu lub obrazu budynku na model przedstawiający budynek. Aby rzutować obraz na model:
  1. Utwórz model, np. stożek, kształt terenu lub front budynku. Na ten model rzutowany będzie obraz.
  2. Wstaw obraz przy użyciu menu Plik > Importuj. Kursor zmieni się w narzędzie Zaznacz z doczepionym obrazem.
  3. Umieść obraz przed modelem, na który będzie rzutowany.
  4. Dostosuj rozmiar obrazu tak, aby był on wystarczająco duży na pokrycie całego modelu.
  5. Kliknij obraz prawym przyciskiem myszy i wybierz opcję Rozbicie, aby przekształcić obraz w rzutowaną teksturę.

    Uwaga! Aby upewnić się, że obraz jest ustawiony w taki sposób, że pokryje cały model, włącz tryb wyświetlania Rentgen.

  6. Wybierz narzędzie Próbna farba (zakraplacz) z przeglądarki materiałów. Zauważ, że po przeciągnięciu narzędzia Próbna farba na obraz na jego końcówce pojawia się kwadrat. Kwadrat ten oznacza, że pracujesz w trybie rzutowania tekstury.
  7. Pobierz próbkę rzutowanej tekstury za pomocą narzędzia Próbna farba.
  8. Nałóż teksturę na płaszczyzny modelu. Obraz zostanie wyświetlony tak, jakby był rzutowany bezpośrednio na płaszczyzny, dostosowując się do konturów modelu.