Za każdym razem, gdy orbitujesz, przesuwasz, powiększasz, rysujesz lub edytujesz, SketchUp renderuje to, co widoczne jest w obszarze rysunku. Im więcej krawędzi, płaszczyzn, stylów, materiałów, itd., tym więcej rzeczy SketchUp musi przeliczyć  podczas pracy z twoim modelem. Postępuj zgodnie z poniższymi wskazówkami, aby utrzymać czystość w swoim modelu i zoptymalizować wydajność programu SketchUp:

  • Trzymaj się prostych stylów. O ile to możliwe, wyłącz cienie, tekstury i efekty specjalne podczas modelowania.

    Wskazówka: Stwórz dwa odrębne style: jeden dla modelowania (szybki), a drugi do prezentacji (który może być wolniejszy). SketchUp posiada domyślnie Szybkie Style, które są przeznaczone do tego celu.

  • Komponenty są twoimi przyjaciółmi. Jeśli korzystasz z tego samego przedmiotu wielokrotnie (na przykład okno lub drzewo), zrób z niego komponent, a następnie używaj kopii komponentu. Kopie tego samego komponentu są lżejsze od wielu kopii jednostki lub grupy.
  • Ukryj geometrię, gdy jej aktualnie nie potrzebujesz. Im więcej geometrii widocznej w modelu, tym wolniejsza praca SketchUp’a. Dla zwiększenia wydajności, najlepszym sposobem, aby ukryć geometrię jest kontrolowanie jej widoczności  warstwami. Na przykład, możesz grupować zdjęcia, elementy krajobrazu, takie jak drzewa i krzewy, meble lub samochody na oddzielnych warstwach następnie włączać i wyłączać ich widoczność.
  • Wybierz JPEG zamiast TIFF. W przypadku importowania obrazów do danego modelu, użyj obrazów JPEG zamiast obrazów TIFF. TIFF mają zazwyczaj duże rozmiary plików i zużywają więcej zasobów obliczeniowych do wyświetlenia.
  • Wyłącz mgłę i cienie. Mgła i cienie zmuszają SketchUp’a do wykonania większej pracy i zazwyczaj nie są konieczne, jeśli nadal rysujesz lub edytujesz model. Jeśli model zawiera cienie, wybierz Widok> Cienie i odznacz pozycję w  menu. Aby wyłączyć mgłę, wybierz Widok> Mgła i odznacz ten element menu.
  • Nie musisz już czyścić danych. Twój model przechowuje elementy, style i materiały, które zostały dodane do modelu nawet jeśli je zastąpiono lub usunięto. SketchUp przechowa te komponenty na później, lecz jeśli wiesz, że nie będziesz miał potrzeby z nich korzystać- SketchUp sam wszystkie usunie. Gdy chcesz oczyścić wszystkie nieużywane elementy naraz, wybierz Okno> Informacje o modelu > Statystyki, a następnie kliknij przycisk Usuń nieużywane.