1. Program SketchUp do poprawnego działania potrzebuje kartę graficzną, która jest zgodna z aktualnymi wymaganiami programu. Rekomendujemy użycie karty dedykowanej jak NVIDIA czy AMD. W przypadku komputerów przenośnych (laptop) należy zweryfikować czy program SketchUp uruchamia się z dedykowaną czy zintegrowaną kartą graficzną.
    W przypadku kart NVIDIA należy kliknąć na ikonę programu SketchUp prawym przyciskiem myszy, następnie wybrać Uruchom z procesorem graficznym i:
    • Jeżeli pozycja Domyślnie jest przypisana do Karta zintegorwana to należy wybrać Procesor NVIDIA o dużej wydajności. Po uruchomieniu programu sprawdzić szybkość jego działania.
    • Jeżeli pozycja Domyślnie jest przypisana do Procesor NVIDIA o dużej wydajności to należy wybrać Karta zintegrowana.  Po uruchomieniu programu sprawdzić szybkość jego działania.
      Jeżeli SketchUp po uruchomieniu na karcie zintegrowanej (pkt nr 1.2.) uruchomił się poprawnie, a na karcie NVIDIA się zawiesza to należy pobrać i zainstalować najnowsze sterowniki dla karty graficznej.Jeżeli SketchUp po uruchomieniu na karcie NVIDIA (pkt nr 1.1.) pracuje poprawnie, to należy przypisać w systemie tą kartę do SketchUp'a. Można to zrobić w następujących krokach:
      • Kliknąć prawym przyciskiem myszy na ikonę programu SketchUp
      • Z menu wybieramy: Uruchom z procesorem graficznym > Zmień domyślny procesor graficzny
      • Powinien otworzyć się Panel sterowania NVIDIA
      • Upewniamy się czy w polu Wybierz program do dostosowania został wybrany SketchUp
      • W polu poniżej Wybierz preferowany procesor graficzny wybieramy Procesor NVIDIA o dużej wydajności
      • Klikamy w Zastosuj
  2. Najczęstszą przyczyną zawieszania się programu jest włączony (domyślnie) autozapis. Uruchamia się on co 5 minut. Wówczas przy większych plikach, które ważą po kilkadziesiąt MB komputer potrzebuje znacznie więcej czasu na ich zapisanie na dysku twardym. Co za tym idzie, co 5 minut program uruchamia autozapis i program nie reaguje w trakcie jego trwania. Jeżeli wykonasz wtedy jakąś akcję, to może to wydłużyć zapis lub nawet wyłączyć program. Warto jest zwiększyć interwały autozapisu z 5 do np. 15 minut lub zupełnie go wyłączyć. Można to zrobić klikając kolejno na Okno > Preferencje > Ogólne.
  3. Wolne działanie programu może wynikać z wagi projektu. Należy co jakiś czas usuwać z niego nieużywane elementy takie jak komponenty czy tekstury, które kiedyś w projekcie były użyte, ale finalnie zostały zastąpione innymi. Wszystkie nieużywane już elementy są przechowywane w pliku i co za tym idzie zwiększają jego wagę. Aby wyczyścić nieużywane elementy należy kliknąć w Okno > Informacje o modelu > Usuń nieużywane.
  4. Kolejną rzeczą, która może spowalniać pracę programu to wyciągnięte do przestrzeni programu SketchUp narzędzia Bryły:
    image
    Należy je usunąć, jeżeli znajdują się w oknie programu SketchUp. Korzystanie z tych narzędzi poza ikonami to kliknięcie w Narzędzia > Bryły